PickerPickObject Method (String, DrawingObject, ViewBase)

Requests the user to pick one object.

Namespace:  Tekla.Structures.Drawing.UI
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public void PickObject(
	string prompt,
	out DrawingObject pickedObject,
	out ViewBase pickedView
)

Parameters

prompt
Type: SystemString
The prompt shown in the status bar before the pick. See the class remarks for more information about prompts.
pickedObject
Type: Tekla.Structures.DrawingDrawingObject
The picked drawing object.
pickedView
Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred.
Exceptions
ExceptionCondition
InvalidPluginPickerInputException Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined.
PickerInterruptedException Thrown when the user interrupts the picker before anything has been picked.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next