AnalysisObjectPickerPickObject Method |
Prompts the user to pick object from the model with the given prompt.
Object is either analysis object or model object.
Namespace: Tekla.Structures.Analysis.UI
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public AnalysisObject PickObject( string analysisModelName, AnalysisObjectPickerPickObjectType type, string prompt )
Parameters
- analysisModelName
- Type: SystemString
The analysis model name. - type
- Type: Tekla.Structures.Analysis.UIAnalysisObjectPickerPickObjectType
The type of object to pick. - prompt
- Type: SystemString
The string to display as user guidance.
Return Value
Type: AnalysisObjectThe analysis object instance.
See Also