Part Class

The Part class represents a part in the model. A part can be either a beam, a polybeam or a contour plate.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public abstract class Part : ModelObject, 
	IAssemblable

The Part type exposes the following members.

Constructors
  NameDescription
Public methodPart
Initializes a new instance of the Part class with default attributes.

The default values are set as follows:

  • Position = new Position();
  • Profile = new Profile();
  • Material = new Material();
  • DeformingData = new DeformingData();
  • Name = "";
  • Class = "";
  • Finish = "";
  • PartNumber = new NumberingSeries("P", 1);
  • AssemblyNumber = new NumberingSeries("A", 1);
  • CastUnitType = CastUnitTypeEnum.PRECAST;
Top
Properties
  NameDescription
Public propertyAssemblyNumber
Gets or sets the assembly number. Defines the numbering in the assembly sense.
Public propertyCastUnitType
Gets or sets the cast unit type of the part.
Public propertyClass
Gets or sets the class of the part.
Public propertyDeformingData
Gets or sets the deforming data of the part.
Public propertyFinish
Gets or sets the finish of the part.
Public propertyMaterial
Gets or sets the material the part is made of.
Public propertyName
Gets or sets the name of the part.
Public propertyPartNumber
Gets or sets the part number. Defines the numbering in the part sense.
Public propertyPosition
Gets or sets the part position. Defines the way the part is positioned in the model.
Public propertyPourPhase
Gets or sets the pour phase of the part.
Public propertyProfile
Gets or sets the profile of the part.
Top
Methods
  NameDescription
Public methodCompareTo(Part)
Compares the instantiated part with another one.
Public methodGetAssembly
Returns the assembly that the part belongs to.
Public methodGetBolts
Returns an enumerator of all the connected bolts.
Public methodGetBooleans
Returns an enumerator of all the connected boolean objects.
Public methodGetCenterLine
Returns the center line for the given part.
Public methodGetComponents
Returns an enumerator of all the connected components, connections, seams and details inherited from the base component.
Public methodGetDSTVCoordinateSystem
Get DSTV coordinate system.
Public methodGetPartMark
Returns the part mark.
Public methodGetPours
Returns an enumerator of all the pours that the part belongs to.
Public methodGetReferenceLine
Returns the reference line for the given part.
Public methodGetReinforcements
Returns an enumerator of all the connected reinforcements.
Public methodGetSolid
Returns the solid of the part.
Public methodGetSolid(FormingStates)
Returns the solid of the part.
Public methodGetSolid(SolidSolidCreationTypeEnum)
Returns the solid of the part.
Public methodGetSurfaceObjects
Returns an enumerator of all the connected surface objects.
Public methodGetSurfaceTreatments
Returns an enumerator of all the connected surface treatments.
Public methodGetWelds
Returns an enumerator of all the connected welds.
Top
See Also
Inheritance Hierarchy
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next