Part Class

The Part class represents a part in the model. A part can be either a beam, a polybeam or a contour plate.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public abstract class Part : ModelObject, 
	IAssemblable

The Part type exposes the following members.

Constructors
  NameDescription
Public methodPart
Initializes a new instance of the Part class with default attributes.

The default values are set as follows:

  • Position = new Position();
  • Profile = new Profile();
  • Material = new Material();
  • DeformingData = new DeformingData();
  • Name = "";
  • Class = "";
  • Finish = "";
  • PartNumber = new NumberingSeries("P", 1);
  • AssemblyNumber = new NumberingSeries("A", 1);
  • CastUnitType = CastUnitTypeEnum.PRECAST;
Top
Properties
  NameDescription
Public propertyAssemblyNumber
Gets or sets the assembly number. Defines the numbering in the assembly sense.
Public propertyCastUnitType
Gets or sets the cast unit type of the part.
Public propertyClass
Gets or sets the class of the part.
Public propertyDeformingData
Gets or sets the deforming data of the part.
Public propertyFinish
Gets or sets the finish of the part.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyMaterial
Gets or sets the material the part is made of.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyName
Gets or sets the name of the part.
Public propertyPartNumber
Gets or sets the part number. Defines the numbering in the part sense.
Public propertyPosition
Gets or sets the part position. Defines the way the part is positioned in the model.
Public propertyPourPhase
Gets or sets the pour phase of the part.
Public propertyProfile
Gets or sets the profile of the part.
Top
Methods
  NameDescription
Public methodCompareTo(Object)
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodCompareTo(Part)
Compares the instantiated part with another one.
Public methodDelete
Deletes the instance from the model database.
(Inherited from ModelObject.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAssembly
Returns the assembly that the part belongs to.
Public methodGetBolts
Returns an enumerator of all the connected bolts.
Public methodGetBooleans
Returns an enumerator of all the connected boolean objects.
Public methodGetCenterLine
Returns the center line for the given part.
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetComponents
Returns an enumerator of all the connected components, connections, seams and details inherited from the base component.
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDSTVCoordinateSystem
Get DSTV coordinate system.
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPartMark
Returns the part mark.
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetPours
Returns an enumerator of all the pours that the part belongs to.
Public methodGetReferenceLine
Returns the reference line for the given part.
Public methodGetReinforcements
Returns an enumerator of all the connected reinforcements.
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetSolid
Returns the solid of the part.
Public methodGetSolid(FormingStates)
Returns the solid of the part.
Public methodGetSolid(SolidSolidCreationTypeEnum)
Returns the solid of the part.
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetSurfaceObjects
Returns an enumerator of all the connected surface objects.
Public methodGetSurfaceTreatments
Returns an enumerator of all the connected surface treatments.
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodGetWelds
Returns an enumerator of all the connected welds.
Public methodInsert
Inserts the model object instance into the model database.
(Inherited from ModelObject.)
Public methodModify
Modifies the model instance in the model database.
(Inherited from ModelObject.)
Public methodSelect
Selects the model object instance from the model database.
(Inherited from ModelObject.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
See Also
Inheritance Hierarchy
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next