ParametricProfileItem Class

The ParametricProfileItem class contains information from parametric profiles in the catalog. Parametric profile items can be enumerated using a profile item enumerator.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsProfileItem
    Tekla.Structures.CatalogsParametricProfileItem

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public sealed class ParametricProfileItem : ProfileItem

The ParametricProfileItem type exposes the following members.

Constructors
  NameDescription
Public methodParametricProfileItem
Creates a new parametric profile item instance.
Top
Properties
  NameDescription
Public propertyaProfileItemCrossSections
The list of profile item cross-sections.
(Inherited from ProfileItem.)
Public propertyaProfileItemParameters
An array list with the profile item parameters.
(Inherited from ProfileItem.)
Public propertyIsMultiCrossSectionUserParametric
Whether the profile is a parametric user-defined multi cross section profile.
(Inherited from ProfileItem.)
Public propertyIsSketchedUserParametric
Whether the profile is a parametric user-defined sketched profile.
(Inherited from ProfileItem.)
Public propertyNumberOfCrossSections
The number of cross sections in the profile item.
(Inherited from ProfileItem.)
Public propertyParameterString
The profile item parameter string.
(Inherited from ProfileItem.)
Public propertyProfileItemSubType
The profile item subtype.
(Inherited from ProfileItem.)
Public propertyProfileItemType
The profile item type.
(Inherited from ProfileItem.)
Public propertyProfilePrefix
The parametric profile item prefix.
Top
Methods
  NameDescription
Public methodCreateProfileString
Gets the parametric profile item prefix and adds parameter values.
Public methodCode exampleExport
Exports the profile item in the profile database to given file name. Currently library profiles, sketch profiles and clb profiles are supported. Library profiles are exported to *.lis format. Sketch profiles are exported to *.uel format. Clb profiles are exported to *.clb format. If path is not given profile is exported to model folder. If filename is empty profile name or prefix is used as filename.
(Inherited from ProfileItem.)
Public methodCode exampleGetCrossSection
Returns list of cross section points of inner surfaces from the profile item.
(Inherited from ProfileItem.)
Public methodGetHighAccuracyCrossSection
Get cross section with high accuracy.
(Inherited from ProfileItem.)
Public methodStatic memberGetParametricProfilePrefix
Gets the parametric profile item prefix using the given subtype. This can be used after retrieving a library profile that has a parametric user-defined type.
Public methodGetProfileItemSubTypes
Selects the profile item and updates the sub types in the profile database.
(Inherited from ProfileItem.)
Public methodIsProfileUserDefined
Whether the profile is a fixed user-defined profile.
(Inherited from ProfileItem.)
Public methodIsProfileUserParametric
Whether the profile is a parametric user-defined profile. If so, the prefix can be asked by type and subtype.
(Inherited from ProfileItem.)
Public methodModifyProfileItemAnalysisParameter
Modify analysis parameter of library profile item. Modify is needed for profile item for updating changes to profile database
(Inherited from ProfileItem.)
Public methodModifyProfileItemParameter
Modify parameter of library profile item. Modify is needed for profile item for updating changes to profile database
(Inherited from ProfileItem.)
Public methodModifyProfileItemUserParameter
Modify user parameter of library profile item. Modify is needed for profile item for updating changes to profile database
(Inherited from ProfileItem.)
Public methodSelect
Selects the profile item in the profile database.
(Inherited from ProfileItem.)
Public methodSelect(String)
Selects the parametric profile item in the profile database using the given name.
Top
Examples
It is possible to select a parametric profile item by its name:
using Tekla.Structures.Catalogs;

public class Example
{
       public void Example1()
       {
           ParametricProfileItem ParametricProfileItem = new ParametricProfileItem();
           ParametricProfileItem.ProfilePrefix = "PHI";
           ParametricProfileItem.Select();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next