ParametricProfileItem Class

The ParametricProfileItem class contains information from parametric profiles in the catalog. Parametric profile items can be enumerated using a profile item enumerator.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsProfileItem
    Tekla.Structures.CatalogsParametricProfileItem

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public sealed class ParametricProfileItem : ProfileItem

The ParametricProfileItem type exposes the following members.

Constructors
  NameDescription
Public methodParametricProfileItem
Creates a new parametric profile item instance.
Top
Properties
  NameDescription
Public propertyProfilePrefix
The parametric profile item prefix.
Top
Methods
  NameDescription
Public methodCreateProfileString
Gets the parametric profile item prefix and adds parameter values.
Public methodStatic memberGetParametricProfilePrefix
Gets the parametric profile item prefix using the given subtype. This can be used after retrieving a library profile that has a parametric user-defined type.
Public methodSelect(String)
Selects the parametric profile item in the profile database using the given name.
Top
Examples
It is possible to select a parametric profile item by its name:
using Tekla.Structures.Catalogs;

public class Example
{
       public void Example1()
       {
           ParametricProfileItem ParametricProfileItem = new ParametricProfileItem();
           ParametricProfileItem.ProfilePrefix = "PHI";
           ParametricProfileItem.Select();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next