OkApplyCancel Class |
The OkApplyCancel class represents a control including the Ok-Apply-Cancel button group.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsOkApplyCancel
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsOkApplyCancel
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The OkApplyCancel type exposes the following members.
Constructors
Name | Description | |
---|---|---|
OkApplyCancel |
Initializes a new instance of the OkApplyCancel class.
|
Events
Name | Description | |
---|---|---|
ApplyClicked |
The ApplyClicked event is raised when the Apply button is clicked.
| |
CancelClicked |
The CancelClicked event is raised when the Cancel button is clicked.
| |
OkClicked |
The OkClicked event is raised when the Ok button is clicked.
|
See Also