MatrixMultiply Operator (Matrix, IEnumerablePoint)

Transforms the given points using the given matrix.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static IEnumerable<Point> operator *(
	Matrix A,
	IEnumerable<Point> Points
)

Parameters

A
Type: Tekla.Structures.Geometry3dMatrix
The transformation matrix.
Points
Type: System.Collections.GenericIEnumerablePoint
The points to be transformed.

Return Value

Type: IEnumerablePoint
The new transformed points.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next