MultiDrawing Class |
The MultiDrawing class is for handling multidrawings.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawing
Tekla.Structures.DrawingMultiDrawing
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawing
Tekla.Structures.DrawingMultiDrawing
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The MultiDrawing type exposes the following members.
Properties
Name | Description | |
---|---|---|
Methods
Name | Description | |
---|---|---|
CommitChanges(String) |
Commits the changes made to the drawings database so far.
Commit inserts a kind of save-point into the database and the save-point will be retrieved if the user does undo.
Commit also executes all messages.
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
Insert |
Not supported.
Modify |
Applies the changes made to the drawing attributes.
Select |
Selects the drawing.
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
See Also