MultiDrawing Class |
The MultiDrawing class is for handling multidrawings.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawing
Tekla.Structures.DrawingMultiDrawing
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawing
Tekla.Structures.DrawingMultiDrawing
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The MultiDrawing type exposes the following members.
Properties
Name | Description | |
---|---|---|
CommitMessage |
Gets the commit message
(Inherited from Drawing.) | |
CreationDate |
The drawing creation date.
(Inherited from Drawing.) | |
DrawingTypeStr |
The type of the drawing
(Inherited from Drawing.) | |
IsFrozen |
Describes whether the drawing is frozen.
(Inherited from Drawing.) | |
IsIssued |
Describes whether the drawing is issued.
(Inherited from Drawing.) | |
IsIssuedButModified |
Describes whether the drawing is issued but modified since it was issued.
(Inherited from Drawing.) | |
IsLocked |
Describes whether the drawing is locked.
(Inherited from Drawing.) | |
IsLockedBy |
Gets the logged in username that set the drawing to locked
(Inherited from Drawing.) | |
IsMasterDrawing |
Describes whether the drawing is a master drawing (shown with a special symbol on the drawing list).
(Inherited from Drawing.) | |
IsReadyForIssue |
Describes whether the drawing is ready for issue.
(Inherited from Drawing.) | |
IsReadyForIssueBy |
Gets the logged in username that set the drawing Ready for issue
(Inherited from Drawing.) | |
IssuingDate |
The drawing issuing date.
(Inherited from Drawing.) | |
Layout |
Gets the drawing layout attributes.
(Inherited from Drawing.) | |
Mark |
The drawing mark.
(Inherited from Drawing.) | |
ModificationDate |
The drawing modification date.
(Inherited from Drawing.) | |
Name |
The name of the drawing.
(Inherited from Drawing.) | |
OutputDate |
The drawing output date. XS_DISABLE_DRAWING_PLOT_DATE controls whether this date is set.
(Inherited from Drawing.) | |
QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) | |
SectionViewStartLabel |
Gets the drawing attribute for start label of section view
(Inherited from Drawing.) | |
Title1 |
The first drawing title.
(Inherited from Drawing.) | |
Title2 |
The second drawing title.
(Inherited from Drawing.) | |
Title3 |
The third drawing title.
(Inherited from Drawing.) | |
UpToDateStatus |
Gets the drawing up to date status.
(Inherited from Drawing.) |
Methods
Name | Description | |
---|---|---|
CommitChanges |
Commits the changes made to the drawings database so far.
Commit inserts a kind of save-point into the database and the save-point will be retrieved if the user does undo.
Commit also executes all messages.
Please note that you need to also to save the drawings database to persists the changes to disk.
(Inherited from Drawing.) | |
CommitChanges(String) |
Commits the changes made to the drawings database so far.
Commit inserts a kind of save-point into the database and the save-point will be retrieved if the user does undo.
Commit also executes all messages.
Please note that you need to also to save the drawings database to persists the changes to disk.
(Inherited from Drawing.) | |
Delete |
Deletes the drawing. An active drawing cannot be deleted.
(Inherited from Drawing.) | |
GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetPlotFileName | Get plot file name. (Inherited from Drawing.) | |
GetPlotFileNameExt | Get plot file name. (Inherited from Drawing.) | |
GetSheet |
Gets the sheet of the drawing.
(Inherited from Drawing.) | |
GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
Insert |
Not supported.
(Overrides DatabaseObjectInsert.) | |
IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from Drawing.) | |
Modify |
Applies the changes made to the drawing attributes.
(Overrides DatabaseObjectModify.) | |
PlaceViews |
Places views on the sheet.
Computes the required size of the views to fit the parts, then places the views so that they fit on the sheet and do not overlap.
Adjusts the sheet size if needed.
(Inherited from Drawing.) | |
Select |
Selects the drawing.
(Overrides DatabaseObjectSelect.) | |
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) | |
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
See Also