OperationMoveAnalysisPartPosition Method

Moves the analysis part position by translation vector. Only the handle positions can be moved.

Namespace:  Tekla.Structures.Analysis.Operations
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static bool MoveAnalysisPartPosition(
	AnalysisPart analysisPart,
	AnalysisNode node,
	Vector translation
)

Parameters

analysisPart
Type: Tekla.Structures.AnalysisAnalysisPart
The analysis part.
node
Type: Tekla.Structures.AnalysisAnalysisNode
The node.
translation
Type: Tekla.Structures.Geometry3dVector
The vector for moving the position.

Return Value

Type: Boolean
True on success, false on failure.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next