ModuleManagerProgramConfigurationEnum Enumeration |
The configuration information of the program.
Namespace: Tekla.Structures
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
CONFIGURATION_VIEWER | 0 | The viewer configuration. | |
CONFIGURATION_PRODUCTION_PLANNER | 1 | The production planner configuration. | |
CONFIGURATION_DRAFTER | 2 | The drafter configuration. | |
CONFIGURATION_PROJECT_MANAGEMENT | 3 | The project management configuration. | |
CONFIGURATION_ENGINEERING | 4 | The construction management configuration. | |
CONFIGURATION_REINFORCED_CONCRETE_DETAILING | 5 | The reinforced concrete detailing configuration. | |
CONFIGURATION_PRECAST_CONCRETE_DETAILING | 6 | The precast concrete detailing configuration. | |
CONFIGURATION_STEEL_DETAILING | 7 | The steel detailing configuration. | |
CONFIGURATION_FULL | 8 | The full detailing configuration. | |
CONFIGURATION_PRIMARY | 9 | The Primary configuration. | |
CONFIGURATION_EDUCATIONAL | 10 | The educational configuration. | |
CONFIGURATION_DEVELOPER | 11 | The developer configuration. | |
CONFIGURATION_CONSTRUCTION_MODELING | 12 | The construction management configuration with modeling capabilities. | |
CONFIGURATION_STEEL_DETAILING_LIMITED | 9 | The old steel detailing limited configuration. This definition was left here to enable old macros in 19.0. | |
CONFIGURATION_CONSTRUCTION_VIEWER | 12 | The construction management configuration restricted to viewer mode. | |
CONFIGURATION_CONSTRUCTION_MANAGEMENT | 12 | ||
CONFIGURATION_PARTNER | 13 | The partner configuration. | |
CONFIGURATION_EPM_MODELER | 14 | The EPM Modeler configuration. | |
CONFIGURATION_CARBON | 15 | The Carbon configuration. | |
CONFIGURATION_GRAPHITE | 16 | The Graphite configuration. | |
CONFIGURATION_DIAMOND | 17 | The Diamond configuration. | |
CONFIGURATION_MEP | 18 | The MEP configuration. | |
CONFIGURATION_TRIAL | 19 | The Trial Configuration. | |
CONFIGURATION_PLATFORM | 20 | The Tekla Platform configuration. |
See Also