ModifiedObjectInfo Structure

Modification info returned by History.

Namespace:  Tekla.Structures.Model.History
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public struct ModifiedObjectInfo

The ModifiedObjectInfo type exposes the following members.

Fields
  NameDescription
Public fieldIsAttributeChanged
Whether the object attribute (UDA) has changed.
Public fieldIsCreated
Whether the object was created
Public fieldIsModified
Whether the object's has changed in a way that affects its numbering. This can include some UDA change.
Public fieldIsNumberingChanged
Whether the numbering of object has changed.
Public fieldModelObject
Gets the object modified.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next