ModelObjectModelObjectEnum Enumeration |
All possible concrete model object subclasses are defined here. This enumeration can be used to
fetch certain types of objects from the Tekla Structures model.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
UNKNOWN | 0 | The unknown model object. | |
BEAM | 1 | The beam. | |
POLYBEAM | 2 | The polybeam. | |
CONTOURPLATE | 3 | The contour plate. | |
BOOLEANPART | 4 | The boolean part. | |
FITTING | 5 | The fitting. | |
CUTPLANE | 6 | The cutplane. | |
SURFACE_TREATMENT | 7 | The surface treatment. | |
WELD | 8 | The weld. | |
ASSEMBLY | 9 | The assembly. | |
SINGLEREBAR | 10 | The single rebar. | |
REBARGROUP | 11 | The rebar group. | |
REBARMESH | 12 | The rebar mesh. | |
REBARSTRAND | 13 | The rebar strand. | |
CONTROL_PLANE | 14 | The control plane. | |
BOLT_ARRAY | 15 | The bolt array. | |
BOLT_CIRCLE | 16 | The bolt circle. | |
BOLT_XYLIST | 17 | The bolt XY list. | |
LOAD_POINT | 18 | The point load. | |
LOAD_LINE | 19 | The line load. | |
LOAD_AREA | 20 | The area load. | |
LOAD_UNIFORM | 21 | The uniform load. | |
GRID | 22 | The grid. | |
GRIDPLANE | 23 | The grid plane. | |
CONNECTION | 24 | The connection. | |
COMPONENT | 25 | The component. | |
SEAM | 26 | The seam. | |
DETAIL | 27 | The detail. | |
REFERENCE_MODEL | 28 | The reference model. | |
REBAR_SPLICE | 29 | The rebar splice. | |
LOAD_GROUP | 30 | The load group. | |
TASK | 31 | The task. | |
TASK_DEPENDENCY | 32 | The task dependency. | |
TASK_WORKTYPE | 34 | The task worktype. | |
POLYGON_WELD | 35 | The polygon weld. | |
LOGICAL_WELD | 36 | The logical weld. | |
CIRCLEREBAR | 37 | The circle rebar. | |
HIERARCHIC_DEFINITION | 38 | The hierarchic definition. | |
HIERARCHIC_OBJECT | 39 | The hierarchic object. | |
ANALYSIS_GEOMETRY | 40 | The analysis geometry. | |
ANALYSIS_PART | 41 | The analysis part. | |
REFERENCE_MODEL_OBJECT | 42 | The reference model object. | |
CUSTOM_PART | 43 | The custom part object. | |
CIRCLE_REBARGROUP | 44 | The circle rebar group. | |
CURVED_REBARGROUP | 45 | The curved rebar group. | |
EDGE_CHAMFER | 46 | The edge chamfer. | |
POUR_OBJECT | 47 | The pour object. | |
POUR_BREAK | 48 | The pour break. | |
CONTROL_LINE | 50 | The control line. | |
LOAD_TEMPERATURE | 51 | The temperature load. | |
BREP | 52 | The Brep part instance. | |
CONTROL_CIRCLE | 53 | The control circle. | |
CONTROL_POINT | 54 | The control point. | |
REBAR_SET | 55 | The rebar set. | |
REBAR_SET_ADDITION | 56 | The rebar set addition. | |
REBAR_PROPERTY_MODIFIER | 57 | The rebar property modifier. | |
REBAR_END_DETAIL_MODIFIER | 58 | The rebar end-detail modifier. | |
REBAR_SPLITTER | 59 | The rebar splitter. | |
CONTROL_ARC | 64 | Construction arc. | |
CONTROL_SPLINE | 65 | Construction spline | |
CONTROL_POLYCURVE | 66 | Construction polycurve | |
RADIAL_GRID | 67 | Radial grid | |
GRID_CYLINDRICAL_SURFACE | 68 | Cylindrical surfaces of radial grids | |
LOFTED_PLATE | 69 | The lofted plate | |
LEG_SURFACE_OBJECT | 70 | The leg surface object. | |
STOREY | 71 | The storey object. | |
SPACE | 72 | The building space object. | |
BUILDING | 73 | The building space object. |
See Also