ModelObjectEnumeratorEnumeratorTypeEnum Enumeration |
The types of enumerator available.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
ALL_SELECTED | 1 | Selects all user selected objects from the model. | |
ALL_OBJECTS | 2 | Selects all objects from the model. | |
MODELOBJECT_CHILDREN | 3 | Selects children of specified type of given ModelObject | |
BY_FILTER_NAME | 4 | Selects all the ModelObjects for a given filter name | |
CONNECTED_COMPONENTS | 5 | Selects all connected components of given ModelObject | |
BY_BOUNDING_BOX | 6 | Selects all objects intersecting with given bounding box | |
ALL_OBJECTS_WITH_TYPE | 7 | All Objects with type given in type in the "subtype". | |
REFERENCE_MODEL_OBJECTS | 8 | Selects sub objects of given ReferenceModel. | |
MODELOBJECT_FATHERS | 9 | Selects fathers of specified type of given ModelObject (Tasks mainly) | |
CONNECTED_DEPENDENCIES | 10 | Selects all connected dependencies of given ModelObject (Tasks mainly) | |
TASKS_OF_SELECTED_OBJECTS | 11 | Selects all tasks of selected objects | |
MODIFIED_OBJECTS_AFTER_STAMP | 12 | Selects all modified and created objects | |
FILTERED_OBJECTS_WITH_TYPE | 13 | Filtered objects with type given in type in the "subtype". | |
DELETED_OBJECTS_AFTER_STAMP | 14 | Selects all modified objects | |
ALL_PRESELECTED | 15 | Selects all preselected objects. | |
BY_BOUNDING_BOX_AND_VIEW | 16 | Selects all objects that intersect with the given bounding box and that are visible in the given view. | |
CONVERTED_FROM_REFERENCE_MODEL | 17 | Selects objects that were converted from a given reference model (if they weren't unlinked) | |
ATTRIBUTE_MODIFIED_OBJECTS_AFTER_STAMP | 18 | Selects all objects of which attributes (UDA) have been modified after the stamp. | |
NUMBERING_MODIFIED_OBJECTS_AFTER_STAMP | 19 | Selects all objects of which numbering has been modified after the stamp. | |
CREATED_OBJECTS_AFTER_STAMP | 20 | Selects all created objects | |
MODIFIED_OBJECTS_BY_FILTER_NAME | 21 | Selects all objects which are new, modified, numbered or which phase has changed after the stamp and pass the filter of given name. | |
PHASE_MODIFIED_OBJECTS_AFTER_STAMP | 22 | Selects all objects of which phase has been modified after the stamp. | |
OBJECTS_WITH_ANY_MODIFICATION_AFTER_STAMP | 23 | Selects all objects with any type of modification or are created after the stamp. | |
BY_MODEL_OBJECT_TYPE | 25 | Selects all model objects with the specified type. |
See Also