ModelObject Class |
The ModelObject class is an abstract class for all model objects in the drawing side.
The model objects of the drawing side contain identifiers of the actual model objects in the model database.
The model objects appear and disappear based on current view properties (view size, settings).
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
More...
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
More...
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ModelObject type exposes the following members.
Properties
Name | Description | |
---|---|---|
Hideable |
Accesses the information if this object is hidden or not or if it should be.
| |
ModelIdentifier |
The database identifier of the model object in the model database.
By using this identifier, it is possible to select the actual object
in the Tekla Structures model.
Methods
Name | Description | |
---|---|---|
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
IsEqual |
Compares the current object with the given object.
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
See Also
Reference
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingBolt
Tekla.Structures.DrawingConnection
Tekla.Structures.DrawingEdgeChamfer
Tekla.Structures.DrawingGrid
Tekla.Structures.DrawingGridLine
Tekla.Structures.DrawingPart
Tekla.Structures.DrawingPourBreak
Tekla.Structures.DrawingPourObject
Tekla.Structures.DrawingReferenceModel
Tekla.Structures.DrawingReinforcementBase
Tekla.Structures.DrawingSurfacing
Tekla.Structures.DrawingWeld
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingModelObject
Tekla.Structures.DrawingBolt
Tekla.Structures.DrawingConnection
Tekla.Structures.DrawingEdgeChamfer
Tekla.Structures.DrawingGrid
Tekla.Structures.DrawingGridLine
Tekla.Structures.DrawingPart
Tekla.Structures.DrawingPourBreak
Tekla.Structures.DrawingPourObject
Tekla.Structures.DrawingReferenceModel
Tekla.Structures.DrawingReinforcementBase
Tekla.Structures.DrawingSurfacing
Tekla.Structures.DrawingWeld