ModelInfo Class |
The ModelInfo class provides information about the currently open Tekla Structures
model.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The ModelInfo type exposes the following members.
Properties
Name | Description | |
---|---|---|
CurrentPhase | The number of the Tekla Structures model's current phase. | |
ModelName | The name of the Tekla Structures model. | |
ModelPath | The path to the Tekla Structures model. | |
NorthDirection | The north direction of the current Tekla Structures model. | |
SharedModel | The read-only property of the Tekla Structures model's sharing status. | |
SingleUserModel | The read-only property if the Tekla Structures model is a single user model. |
Examples
When Tekla Structures is running the length of the model name tells you whether the model
is open.
using Tekla.Structures.Model; using System.Windows.Forms; public class Example { public void Example1() { Model CurrentModel = new Model(); ModelInfo Info = CurrentModel.GetInfo(); if (CurrentModel.GetConnectionStatus()) { if (Info.ModelName.Length == 0) { MessageBox.Show("A Tekla Structures model is not open."); } } } }
See Also