MaterialSelectionForm Constructor (ListMaterialItem, String)

Creates a new instance of the MaterialSelectionForm, selecting the given material in the tree control.

Namespace:  Tekla.Structures.Dialog.UIControls
Assembly:  Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public MaterialSelectionForm(
	List<MaterialItem> Materials,
	string Material
)

Parameters

Materials
Type: System.Collections.GenericListMaterialItem
The materials to be added to the dialog.
Material
Type: SystemString
The material to be selected in the tree.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next