MaterialItemMaterialItemTypeEnum Enumeration |
Defines the different material item types.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Members
Member name | Value | Description | |
---|---|---|---|
MATERIAL_UNKNOWN | 0 | The unknown material item type. | |
MATERIAL_STEEL | 1 | The steel material type. | |
MATERIAL_CONCRETE | 2 | The concrete material type. | |
MATERIAL_TIMBER | 3 | The timber material type. | |
MATERIAL_MISC | 4 | The miscellaneous material type. | |
MATERIAL_REBAR | 5 | The rebar material type. | |
MATERIAL_REBAR_MESH | 6 | The rebar mesh material type. |
See Also