MaterialItem Class |
The MaterialItem class contains information about the materials in the Tekla Structures catalog.
Inheritance Hierarchy
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The MaterialItem type exposes the following members.
Constructors
Name | Description | |
---|---|---|
MaterialItem |
Creates a new material item instance.
|
Properties
Name | Description | |
---|---|---|
AliasName1 |
The material item's alias name 1.
| |
AliasName2 |
The material item's alias name 2.
| |
AliasName3 |
The material item's alias name 3.
| |
DesignCode |
The design code.
| |
MaterialName |
The material item's name.
| |
ModulusOfElasticity |
Thte modulus of elasticity in unit N/m2.
| |
PlateDensity |
The plate density in unit kg/m3.
| |
PoissonsRatio |
The poissons ratio
| |
ProfileDensity |
The profile density in unit kg/m3.
| |
ThermalDilatation |
The thermal dilatation in unit 1/K.
| |
Type |
The material item's type.
|
Methods
Name | Description | |
---|---|---|
Delete |
Delete this material from material database.
| |
Export |
Exports the material item in the material database to given file name.
Materials are exported to *.lis format.
If path is not given material is exported to model folder.
If filename is empty material name is used as filename.
| |
Insert |
Inserts this material item to material database.
| |
MaterialNameMaxLength |
Returns the maximum length a material name can be.
| |
Modify |
Modifies the material in material database that has the same name as this instance.
| |
Select |
Selects the material item from the database based on the material name and alias name
in this instance.
| |
Select(String) |
Selects the material item based on the name from the material database.
The material name can also be an alias name.
|
See Also