Material Class |
The Material class represents a single material that parts can be made of.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Material type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
MaterialString |
Identifies the material in a string format.
|
Examples
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { Beam beam = new Beam(new Point(5000, 7000, 0), new Point(6000, 7000, 0)); beam.Material.MaterialString = "K40-1"; beam.Profile.ProfileString = "250*250"; beam.Finish = "PAINT"; bool result = false; result = beam.Insert(); } }
See Also