MaterialCatalog Class |
The MaterialCatalog class represents a group of controls to select materials
using the material catalog.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsMaterialCatalog
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsMaterialCatalog
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The MaterialCatalog type exposes the following members.
Constructors
Name | Description | |
---|---|---|
MaterialCatalog |
Initiates a new instance of the control.
| |
MaterialCatalog(String) |
Creates a new instance of the MaterialCatalog and will select
the material (if available) in the tree.
|
Properties
Name | Description | |
---|---|---|
ButtonText |
Gets and sets the text of the button control.
| |
SelectedMaterial |
Gets the selected material in the control.
|
Events
Name | Description | |
---|---|---|
SelectClicked |
The SelectClicked event is raised when the Select button is clicked.
| |
SelectionDone |
The SelectionDone event is raised when the selection has been done.
|
See Also