MarkSetMarkSetAttributes Class |
The MarkSetAttributes class is the attribute class for the mark set.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingMarkBaseMarkBaseAttributes
Tekla.Structures.DrawingMarkSetMarkSetAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingMarkBaseMarkBaseAttributes
Tekla.Structures.DrawingMarkSetMarkSetAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The MarkSetMarkSetAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
MarkSetMarkSetAttributes | Initializes a new instance of the MarkSetMarkSetAttributes class |
Properties
Name | Description | |
---|---|---|
PlacingAttributes |
The placing attributes that the object should use.
PreferredPlacing |
The type of placing the object should use.
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file. Not implemented yet.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also