MarkMarkAttributes Class |
The MarkAttributes class defines the mark attributes.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingMarkBaseMarkBaseAttributes
Tekla.Structures.DrawingMarkMarkAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingMarkBaseMarkBaseAttributes
Tekla.Structures.DrawingMarkMarkAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The MarkMarkAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
MarkMarkAttributes(ModelObject) |
Creates a new default mark attributes instance that loads standard attributes.
| |
MarkMarkAttributes(ModelObject, String) |
Creates a new mark attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
Angle |
The actual angle of the mark, in degrees. Can differ from the rotation angle
set by the user for marks, e.g. 45-degree column marks in GA drawings or
when placing mark along part edges.
(Inherited from MarkBaseMarkBaseAttributes.) | |
ArrowHead |
The arrowhead of the leader line(s).
(Inherited from MarkBaseMarkBaseAttributes.) | |
Content |
The mark content as a list of elements.
| |
CustomPresentation |
Custom presentation GUID to be applied to the object type
(Inherited from MarkBaseMarkBaseAttributes.) | |
Frame |
The frame attributes of the mark's labels.
(Inherited from MarkBaseMarkBaseAttributes.) | |
PlacingAttributes |
The placing attributes that the object should use.
Using these you can specify whether the object is automatically arranged in the drawing or not.
(Inherited from MarkBaseMarkBaseAttributes.) | |
PreferredPlacing |
The type of placing the object should use.
See the preferred placing types for different types of placing.
(Inherited from MarkBaseMarkBaseAttributes.) | |
RotationAngle |
The mark rotation angle set by the user. Unit is degrees.
(Inherited from MarkBaseMarkBaseAttributes.) | |
TextAlignment |
The mark text alignment.
(Inherited from MarkBaseMarkBaseAttributes.) | |
TransparentBackground |
The mark text background transparency. (transparent/opaque)
(Inherited from MarkBaseMarkBaseAttributes.) |
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also