MarkBase Class |
The MarkBase class contains general mark information and can be
selected and modified with the general attributes.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingMarkBase
Tekla.Structures.DrawingMark
Tekla.Structures.DrawingMarkSet
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingMarkBase
Tekla.Structures.DrawingMark
Tekla.Structures.DrawingMarkSet
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The MarkBase type exposes the following members.
Properties
Name | Description | |
---|---|---|
Attributes |
Gets or sets the mark base attributes.
| |
Hideable |
Accesses the information if this object is hidden or not or if it should be.
| |
InsertionPoint |
The insertion point of the mark.
| |
IsAssociativeNote |
Gets a value indicating whether the mark is an associative note.
| |
Placing |
The current placing of the object.
See the placing types for different placing options.
Methods
Name | Description | |
---|---|---|
GetAxisAlignedBoundingBox |
Returns the axis aligned bounding box of the text (rectangle format).
GetObjectAlignedBoundingBox |
Returns the object aligned bounding box of the text (rectangle format).
| |
GetObjects |
Gets the children objects of the current object.
| |
GetObjects(Type) |
Gets the children objects of the current object that are of certain types.
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
IsEqual |
Compares the current object with the given object.
MoveObjectRelative |
Moves the object using the move vector.
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
Examples
The following example enumerates through all marks in all views and changes
their frame types to sharpened and their frame colors to red.
using Tekla.Structures.Drawing; public class Example { public void Example1() { DrawingHandler MyDrawingHandler = new DrawingHandler(); if(MyDrawingHandler.GetConnectionStatus()) { MarkBase MyMarkBase; DrawingObjectEnumerator views = MyDrawingHandler.GetActiveDrawing().GetSheet().GetAllViews(); while(views.MoveNext()) { DrawingObjectEnumerator allObjects = (views.Current as ViewBase).GetAllObjects(); while(allObjects.MoveNext()) { if(allObjects.Current is MarkBase) { MyMarkBase = allObjects.Current as MarkBase; MyMarkBase.Attributes.Frame.Color = DrawingColors.Red; MyMarkBase.Attributes.Frame.Type = FrameTypes.Sharpened; MyMarkBase.Modify(); } } } } } }
See Also