Localization Class |
The Localization class is for translating strings in .NET dialogs.
Inheritance Hierarchy
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Localization type exposes the following members.
Constructors
Name | Description | |
---|---|---|
Localization |
Creates a new localization instance.
| |
Localization(String, String) |
Creates a new localization instance.
|
Properties
Name | Description | |
---|---|---|
DefaultLocalizationFile |
The path and name of the default localization file.
| |
DefaultLocalizationPath | Obsolete.
The path and directory name where to find localization files.
| |
Language |
Gets or sets the language that is currently used in Tekla Structures.
|
Methods
Name | Description | |
---|---|---|
GetLocalizationFileFullPath |
Returns localization file if found from environment
| |
GetText |
Gets the translation for the current language.
The translations are searched with the given identifier string.
| |
LoadAidFile |
Loads the localization strings from an aid file. Several files may be used concurrently,
just call LoadAidFile for each file. The translations are searched in the loading order and the first match is returned.
| |
LoadAilFile |
Loads the localization strings from an ail file. Several files may be used concurrently,
just call LoadAilFile for each file. The translations are searched in the loading order and the first match is returned.
| |
LoadFile |
Loads the localization strings from a file. Several files may be used concurrently,
just call LoadFile for each file. The translations are searched in the loading order and the first match is returned.
The method uses the extension of the filename to identify the file type
(".xml", ".aid" or ".ail").
| |
LoadXMLFile |
Loads the localization strings from an xml file. Several files may be used concurrently,
just call LoadXMLFile for each file. The translations are searched in the loading order and the first match is returned.
| |
Localize(ApplicationSettingsBase) |
Localizes application settings.
| |
Localize(Control) |
Localizes a control recursively.
| |
Localize(MenuItem) |
Localizes a MenuItem control recursively.
| |
LocalizeToolTip |
Localizes a ToolTip control.
| |
RegisterLocalizationCallback |
Registers a localization callback which is used to translate the registered control types.
|
See Also