LoadGroup Class |
The LoadGroup class implements grouping functionality related to all loads.
Each load should be assigned to a load group. Each load group contains loads
caused by the same action and to which you want to refer collectively.
Tekla Structures assumes that all loads in a group
- Have the same partial safety and other combination factors
- Have the same action direction
- Occur at the same time and all together
You may create new load groups, modify existing ones and delete load groups via the .NET interface. You may also change the assigned load group of a load and list all the load groups found in the model via the ModelObjectSelector interface. The model always has at least one load group.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelLoadGroup
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelLoadGroup
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The LoadGroup type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
Color |
The load group color. This variable indicates the color with which all
loads that belong to this same group are drawn in Tekla Structures views.
| |
Compatible |
This variable is used to store information on which groups are compatible
with each other in structural analysis load combination.
Load combination is a process in which some simultaneously acting load groups
are multiplied by their partial safety factors and combined with each other
according to specific rules.
To accurately combine loads which have the same load group type,
you need to identify which load groups can occur at the same time,
i.e. are compatible.
This variable stores one integer, and all groups who have this same integer
are known to be compatible with each other. Depending on the analysis needs,
they may be calculated together, in smaller combinations, or separately.
| |
Direction |
The load group direction.
| |
GroupName |
The load group name. The maximum size is 126 characters.
| |
GroupType |
The load group type.
| |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
Incompatible |
This variable is used to store information on which groups exclude each other
in structural analysis load combination.
Load combination is a process in which some simultaneously acting load groups
are multiplied by their partial safety factors and combined with each other
according to specific rules.
To accurately combine loads which have the same load group type,
you need to identify which load groups exclude each other,
i.e. are incompatible.
This variable stores one integer, and all groups who have this same integer
are known to be incompatible with each other.
| |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) |
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the load group instance with the given ID from the model database.
(Overrides ModelObjectDelete.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts the load group into the model database.
(Overrides ModelObjectInsert.) | |
Modify |
Modifies the existing load group in the model database to match the current one.
At the moment it is not possible to change the load attachment or the father.
(Overrides ModelObjectModify.) | |
Select |
Selects a load group from the model database. The ID must be set.
(Overrides ModelObjectSelect.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
Examples
Creating a new load group:
Selecting and browsing through all load groups:
using Tekla.Structures.Model; public class Example { public void Example1() { LoadGroup WindLoads = new LoadGroup(); WindLoads.GroupName = "ExtremeNorthWind"; WindLoads.GroupType = LoadGroup.LoadGroupType.EUROCODE_WIND_LOAD; WindLoads.Direction = LoadGroup.LoadGroupDirection.DIR_Y; WindLoads.Compatible = 2; WindLoads.Incompatible = 15; WindLoads.Color = LoadGroup.Colors.RED; WindLoads.Insert(); } }
using Tekla.Structures.Model; using System; public class Example { public void Example1() { Model Model = new Model(); ModelObjectEnumerator LoadGroups = Model.GetModelObjectSelector().GetAllObjectsWithType(ModelObject.ModelObjectEnum.LOAD_GROUP); foreach (LoadGroup group in LoadGroups) { Console.WriteLine("Group: " + group.GroupName + "(ID " + group.Identifier.ID + ")"); } } }
See Also