LoadGroup Class |
The LoadGroup class implements grouping functionality related to all loads.
Each load should be assigned to a load group. Each load group contains loads
caused by the same action and to which you want to refer collectively.
Tekla Structures assumes that all loads in a group
- Have the same partial safety and other combination factors
- Have the same action direction
- Occur at the same time and all together
You may create new load groups, modify existing ones and delete load groups via the .NET interface. You may also change the assigned load group of a load and list all the load groups found in the model via the ModelObjectSelector interface. The model always has at least one load group.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelLoadGroup
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelLoadGroup
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The LoadGroup type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
Color |
The load group color. This variable indicates the color with which all
loads that belong to this same group are drawn in Tekla Structures views.
| |
Compatible |
This variable is used to store information on which groups are compatible
with each other in structural analysis load combination.
Load combination is a process in which some simultaneously acting load groups
are multiplied by their partial safety factors and combined with each other
according to specific rules.
To accurately combine loads which have the same load group type,
you need to identify which load groups can occur at the same time,
i.e. are compatible.
This variable stores one integer, and all groups who have this same integer
are known to be compatible with each other. Depending on the analysis needs,
they may be calculated together, in smaller combinations, or separately.
| |
Direction |
The load group direction.
| |
GroupName |
The load group name. The maximum size is 126 characters.
| |
GroupType |
The load group type.
Incompatible |
This variable is used to store information on which groups exclude each other
in structural analysis load combination.
Load combination is a process in which some simultaneously acting load groups
are multiplied by their partial safety factors and combined with each other
according to specific rules.
To accurately combine loads which have the same load group type,
you need to identify which load groups exclude each other,
i.e. are incompatible.
This variable stores one integer, and all groups who have this same integer
are known to be incompatible with each other.
| |
Methods
Name | Description | |
---|---|---|
Delete |
Deletes the load group instance with the given ID from the model database.
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
Insert |
Inserts the load group into the model database.
(Overrides ModelObjectInsert.) | |
Modify |
Modifies the existing load group in the model database to match the current one.
At the moment it is not possible to change the load attachment or the father.
(Overrides ModelObjectModify.) | |
Select |
Selects a load group from the model database. The ID must be set.
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
Examples
Creating a new load group:
Selecting and browsing through all load groups:
using Tekla.Structures.Model; public class Example { public void Example1() { LoadGroup WindLoads = new LoadGroup(); WindLoads.GroupName = "ExtremeNorthWind"; WindLoads.GroupType = LoadGroup.LoadGroupType.EUROCODE_WIND_LOAD; WindLoads.Direction = LoadGroup.LoadGroupDirection.DIR_Y; WindLoads.Compatible = 2; WindLoads.Incompatible = 15; WindLoads.Color = LoadGroup.Colors.RED; WindLoads.Insert(); } }
using Tekla.Structures.Model; using System; public class Example { public void Example1() { Model Model = new Model(); ModelObjectEnumerator LoadGroups = Model.GetModelObjectSelector().GetAllObjectsWithType(ModelObject.ModelObjectEnum.LOAD_GROUP); foreach (LoadGroup group in LoadGroups) { Console.WriteLine("Group: " + group.GroupName + "(ID " + group.Identifier.ID + ")"); } } }
See Also