![]() | LinkBase Class |
The LinkBase class is the base class for links.

SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingLinkBase
Tekla.Structures.DrawingDrawingLink
Tekla.Structures.DrawingHyperLink
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingLinkBase
Tekla.Structures.DrawingDrawingLink
Tekla.Structures.DrawingHyperLink
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63

The LinkBase type exposes the following members.

Name | Description | |
---|---|---|
![]() | Angle |
Gets or sets the angle of the link.
|
![]() | Attributes |
Gets or sets the link attributes.
|
![]() | InsertionPoint |
Gets or sets the insertion point of the link.
|
![]() | QueryReturnValue |
Status information about the latest database operation (select, insert, modify, delete).
(Inherited from DatabaseObject.) |
![]() | Text |
Gets or sets the link text that is visible on the screen.
|

Name | Description | |
---|---|---|
![]() | Delete |
Deletes the instance from the database.
(Inherited from DatabaseObject.) |
![]() | GetAxisAlignedBoundingBox |
Gets the bounding box for the current object in the global axis coordinate system.
|
![]() | GetDoubleUserProperties(DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetDoubleUserProperties(ListString, DictionaryString, Double) |
Retrieves all double user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetDrawing |
Gets the drawing where the drawing object is.
(Inherited from DrawingObject.) |
![]() | GetIntegerUserProperties(DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetIntegerUserProperties(ListString, DictionaryString, Int32) |
Retrieves all integer user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetObjectAlignedBoundingBox |
Gets the bounding box for the current object in its local coordinate system.
|
![]() | GetRelatedObjects |
Gets the related objects of the current object.
(Inherited from DrawingObject.) |
![]() | GetRelatedObjects(Type) |
Gets the related objects of the current object that are of certain types.
(Inherited from DrawingObject.) |
![]() | GetStringUserProperties(DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetStringUserProperties(ListString, DictionaryString, String) |
Retrieves all string user properties for the object with the given list of names.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | GetView |
Gets the view where the drawing object is.
(Inherited from DrawingObject.) |
![]() | Insert |
Inserts the object instance into the database. The inserted instance must be of a real type.
(Inherited from DatabaseObject.) |
![]() | IsEqual |
Compares the current object with the given object.
Checks every field of both objects for equality.
(Inherited from DrawingObject.) |
![]() | IsSameDatabaseObject |
Returns true if the current object and the given object are referencing the same database object.
(Inherited from DatabaseObject.) |
![]() | Modify |
Modifies the instance in the database.
(Inherited from DatabaseObject.) |
![]() | MoveObjectRelative |
Moves the object according to the given move vector.
|
![]() | Resize |
Resizes the object. The scaling type is changed to ScaleToFit.
|
![]() | Select |
Selects the object instance from the database.
(Inherited from DatabaseObject.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
the method can be used.
(Inherited from DatabaseObject.) |
![]() | ToString |
Changes the string presentation of the drawing object.
(Inherited from DrawingObject.) |