![]() | LineTypes Class |
The LineTypes class defines the possible line types that can be used by the drawing objects.
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
SystemObject
Tekla.Structures.DrawingLineTypes
Tekla.Structures.DrawingCustomLineType
Tekla.Structures.DrawingNormalLineType
Tekla.Structures.DrawingLineTypes
Tekla.Structures.DrawingCustomLineType
Tekla.Structures.DrawingNormalLineType
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
The LineTypes type exposes the following members.
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Name | Description | |
---|---|---|
![]() | Clone |
Creates a new object that is a copy of the current instance.
|
![]() ![]() | Custom |
The Custom line type defines a line that is drawn using one of the custom line types, as specified by the CustomLineTypeName.
|
![]() | Equals |
Returns true if the current object and the given object are equal.
(Overrides ObjectEquals(Object).) |
![]() | GetHashCode |
Returns a hash code for the object.
(Overrides ObjectGetHashCode.) |
![]() | IsEqual |
Compares the current object with an object of the same type.
|
![]() | ToString |
Returns the LineTypes information as a string.
(Overrides ObjectToString.) |
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Name | Description | |
---|---|---|
![]() ![]() | Equality |
Returns true if the current object and the given object are equal.
|
![]() ![]() | (Int32 to LineTypes) |
Returns the corresponding LineTypes value of the given int value.
|
![]() ![]() | (LineTypes to Int32) |
Returns the corresponding int value of the given LineTypes value.
|
![]() ![]() | Inequality |
Returns true if the current object and the given object are not equal.
|
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Name | Description | |
---|---|---|
![]() ![]() | DashDot |
The dash dotted line (--.--.).
|
![]() ![]() | DashDoubleDot |
The dash double dotted line (-..-..-).
|
![]() ![]() | DashedLine |
The dashed line (-----).
|
![]() ![]() | DottedLine |
The dotted line (.....).
|
![]() ![]() | SlashDash |
The slash dash line (-- - -- -).
|
![]() ![]() | SlashedLine |
The slashed line (- - -).
|
![]() ![]() | SolidLine |
The solid line (default).
|
![]() ![]() | UndefinedLine |
The line type is undefined.
|
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)