LineTypeAttributes Class |
The LineTypeAttributes class contains basic attributes for lines.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingLineTypeAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingLineTypeAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The LineTypeAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
LineTypeAttributes |
Creates a new line type attributes instance.
| |
LineTypeAttributes(LineTypes, DrawingColors) |
Creates a new line type attributes instance with the given line type and color.
| |
LineTypeAttributes(LineTypes, TeklaDrawingColor) |
Creates a new line type attributes instance with the given line type and color.
|
Properties
Name | Description | |
---|---|---|
Color |
The color of the line (see DrawingColors for options).
| |
TrueColor |
The true color (rgb enabled) of the line.
| |
Type |
The type of the line (see LineTypes for options).
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also