ProjectionLineSegmentToPlane Method |
Returns a new line segment which is a projection of the given line segment onto the given plane.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static LineSegment LineSegmentToPlane( LineSegment LineSegment, GeometricPlane Plane )
Parameters
- LineSegment
- Type: Tekla.Structures.Geometry3dLineSegment
The line segment to be used. - Plane
- Type: Tekla.Structures.Geometry3dGeometricPlane
The plane to be used.
Return Value
Type: LineSegmentThe new projection line segment.
See Also