IntersectionLineSegmentToObb Method

Returns a new line segment which is an intersection of the given line segment and the oriented bounding box or null if the line segment and oriented bounding box do not intersect.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static LineSegment LineSegmentToObb(
	LineSegment lineSegment,
	OBB obb
)

Parameters

lineSegment
Type: Tekla.Structures.Geometry3dLineSegment
Line segment to be used.
obb
Type: Tekla.Structures.Geometry3dOBB
Oriented bounding box to be used.

Return Value

Type: LineSegment
The intersection line segment or null if no intersection was found.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next