LineSegment Class

The LineSegment class represents a single finite segment of a line in 3D space. See Line for the implementation of a straight line.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Geometry3dLineSegment

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public class LineSegment : ICurve, 
	IEquatable<ICurve>

The LineSegment type exposes the following members.

Constructors
  NameDescription
Public methodLineSegment
Instantiates a line segment with both the starting point and the end point zeroed.
Public methodLineSegment(Point, Point)
Instantiates a line segment with the given points.
Top
Properties
  NameDescription
Public propertyEndPoint
Gets the end point of the line segment
Public propertyPoint1
Gets the start point of the line segment
Public propertyPoint2
Gets the end point of the line segment
Public propertyStartPoint
Gets the start point of the line segment
Top
Methods
  NameDescription
Public methodClone
Creates a copy of itself
Public methodEquals(Object)
Returns true if the objects are equal.
(Overrides ObjectEquals(Object).)
Public methodEquals(ICurve)
Returns true if the other curve is a line segment equal to this
Public methodGetDirectionVector
Returns a new unit direction vector of a line segment.
Public methodGetHashCode
Returns a hash code for a line segment. Notice, in extremely rare cases, you might not get the same hash code for two line segments even though they are considered equal! This should, however, happen only in extremely rare cases!
(Overrides ObjectGetHashCode.)
Public methodLength
Returns the length of a line segment.
Top
Operators
  NameDescription
Public operatorStatic memberEquality
Checks the equality of two line segments.
Public operatorStatic memberInequality
Checks the inequality of two line segments.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next