ParallelLineToPlane Method (Line, GeometricPlane, Double)

Returns true if the given line and plane are parallel within the given angular tolerance.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public static bool LineToPlane(
	Line Line,
	GeometricPlane Plane,
	double Tolerance
)

Parameters

Line
Type: Tekla.Structures.Geometry3dLine
The line to be used.
Plane
Type: Tekla.Structures.Geometry3dGeometricPlane
The plane to be used.
Tolerance
Type: SystemDouble
The angular tolerance (in radians) to be used.

Return Value

Type: Boolean
True if the given line and plane are parallel within the given tolerance.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next