IntersectionLineToLine Method |
Returns a new line segment which is the shortest path between the given lines or null if the lines are
parallel. If the resulting line segment has a length of 0.0, the given lines actually intersect
in 3d space.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- line1
- Type: Tekla.Structures.Geometry3dLine
The first line to be used. - line2
- Type: Tekla.Structures.Geometry3dLine
The second line to be used.
Return Value
Type: LineSegmentThe shortest line segment between the given lines or null if the lines are parallel.
See Also