Line Constructor (ViewBase, Point, Point)

Creates a new line instance with two points and no bulge (straight line) using standard attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public Line(
	ViewBase view,
	Point startPoint,
	Point endPoint
)

Parameters

view
Type: Tekla.Structures.DrawingViewBase
The view to be used.
startPoint
Type: Tekla.Structures.Geometry3dPoint
The start point to be used.
endPoint
Type: Tekla.Structures.Geometry3dPoint
The end point to be used.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next