Line Class |
The Line class represents a single infinite line in 3D space. See LineSegment for
the implementation of a segment of a line.
Inheritance Hierarchy
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Line type exposes the following members.
Constructors
Name | Description | |
---|---|---|
Line |
Instantiates a line with an undefined direction.
| |
Line(LineSegment) |
Instantiates a line defined by the given line segment.
| |
Line(Point, Point) |
Instantiates a line defined by the given points.
| |
Line(Point, Vector) |
Instantiates a line defined by the given point and direction vector.
|
Properties
See Also