LevelMarkLevelMarkAttributes Class |
The LevelMarkAttributes class contains the attributes for the level mark.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingLevelMarkLevelMarkAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingLevelMarkLevelMarkAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The LevelMarkLevelMarkAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
LevelMarkLevelMarkAttributes |
Initializes a new instance of the LevelMarkLevelMarkAttributes class that loads standard attributes.
| |
LevelMarkLevelMarkAttributes(String) |
Initializes a new instance of the LevelMarkLevelMarkAttributes class that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
Angle |
Gets or sets the angle of the level mark, in degrees.
| |
ArrowHead |
Gets or sets the arrow attributes for the level mark.
| |
Font |
Gets or sets the font of the level mark text.
| |
Frame |
Gets or sets the frame attributes for the level mark.
| |
PlacingAttributes |
Gets or sets the placing attributes that the object should use.
Using these you can specify whether the object is automatically arranged in the drawing or not.
| |
Postfix |
Gets or sets text after the level value.
| |
Prefix |
Gets or sets the text before the level value.
| |
TextHidden |
Gets or sets a value indicating whether the numeric values are visible or hidden.
| |
TransparentBackground |
Gets or sets a value indicating whether the transparency
of the background of the level mark text is enabled.
| |
Unit |
Gets or sets the unit attributes.
| |
UseGrouping |
Gets or sets a value indicating whether to use different grouping options
to represent the level mark dimensions.
| |
UsePositiveSignForPositiveLevels |
Gets or sets a value indicating whether a + character in front of positive level value.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also