IUIEvents Interface

Interface for the Events class allows the user to register event listeners for DrawingUI events. This interface allows the Marshaling of the Events class with Trimble.Remoting

Namespace:  Tekla.Structures.Drawing.UI
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public interface IUIEvents

The IUIEvents type exposes the following members.

Methods
  NameDescription
Public methodOnInterrupted
Called when uesr interrupts.
Public methodRegister
Registers the instance to listen to the specified events.
Public methodUnRegister
Unregisters the instance from listening to events.
Top
Events
  NameDescription
Public eventDocumentManagerClosed
The DocumentManagerClosed eventis raised when the document manager is closed.
Public eventDrawingEditorClosed
The DrawingEditorClosed event is raised when the drawing editor is closed.
Public eventDrawingEditorOpened
The DrawingEditorOpened event is raised when the drawing editor is opened.
Public eventDrawingListSelectionChanged
The DrawingListSelectionChanged event is raised when selection on the drawing list has changed.
Public eventDrawingLoaded
The DrawingLoaded event is raised when a new drawing is opened in the drawing editor.
Public eventInterrupted
Occurs when user interrupts.
Public eventSelectionChange
The SelectionChange event is raised when the selection is changed in a Tekla Structures drawing.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next