DistanceListItem Property

Gets or sets the item at the specified index.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Examples
This example shows how to access the Distance instances in a DistanceList by index.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           // We'll use this distance list to demonstrate how to access and then 
           // modify items using an index.
           DistanceList distanceList = new DistanceList(new Distance[]
                                                       {
                                                           new Distance(30.2),
                                                           new Distance(30.2),
                                                           new Distance(30.2),
                                                           new Distance(50),
                                                           new Distance(2.3),
                                                           new Distance(2.3),
                                                       });

           for(int i = 0; i < distanceList.Count; i++)
           {
               Distance item = distanceList[i];

               // Modify the item here.

               distanceList[i] = item;
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next