OBBIntersects Method (LineSegment) |
Tests if current OBB intersects with the given LineSegment
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- lineSegment
- Type: Tekla.Structures.Geometry3dLineSegment
LineSegment to test against
Return Value
Type: BooleanTrue if the OBB intersects with the given LineSegment, otherwise false
Exceptions
Exception | Condition |
---|---|
ArgumentNullException | Thrown when null is assigned to the lineSegment parameter. |
See Also