OBBIntersects Method (GeometricPlane)

Tests if current OBB intersects with the given GeometricPlane

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public bool Intersects(
	GeometricPlane geometricPlane
)

Parameters

geometricPlane
Type: Tekla.Structures.Geometry3dGeometricPlane
GeometricPlane to test against

Return Value

Type: Boolean
True if the OBB intersects with the given GeometricPlane, otherwise false
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the geometricPlane parameter.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next