OBBIntersectionWith Method (Line) |
Creates an intersection between the OBB and the given Line.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- line
- Type: Tekla.Structures.Geometry3dLine
Line to calculate against
Return Value
Type: LineSegmentIntersection as LineSegment or null if no intersection was found.
Exceptions
Exception | Condition |
---|---|
ArgumentNullException | Thrown when null is assigned to the line parameter. |
See Also