Intersection Class |
The Intersection class contains methods for calculating intersections between geometric objects.
Inheritance Hierarchy
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Intersection type exposes the following members.
Methods
Name | Description | |
---|---|---|
LineSegmentToObb |
Returns a new line segment which is an intersection of the given line segment and the oriented bounding box
or null if the line segment and oriented bounding box do not intersect.
| |
LineSegmentToPlane |
Returns a new point which is an intersection of the given line segment and plane or null if
the line segment and the plane are parallel or do not intersect.
| |
LineToLine |
Returns a new line segment which is the shortest path between the given lines or null if the lines are
parallel. If the resulting line segment has a length of 0.0, the given lines actually intersect
in 3d space.
| |
LineToObb |
Returns a new line segment which is an intersection of the given line and the oriented bounding box
or null if the line and oriented bounding box do not intersect.
| |
LineToPlane |
Returns a new point which is an intersection of the given line and plane or null if the line and the plane are
parallel.
| |
PlaneToPlane |
Returns a new line which is an intersection of the given two planes or null if the planes are
parallel.
|
See Also