Integer Structure |
The Integer datatype.
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The Integer type exposes the following members.
Constructors
Properties
Methods
Name | Description | |
---|---|---|
Equals |
Returns a value that indicates whether the current instance is equal to the given object.
(Overrides ValueTypeEquals(Object).) | |
GetHashCode |
Returns the hash code for the current instance.
(Overrides ValueTypeGetHashCode.) | |
GetSchema |
Gets the XML Schema for the datatype.
| |
ReadXml |
Parses a new value from the given reader.
| |
ToString |
Returns the string representation of the object.
(Overrides ValueTypeToString.) | |
WriteXml |
Writes the value as XML to the given writer.
|
Operators
Name | Description | |
---|---|---|
Equality |
Compares an int value with a Datatype.Integer value.
| |
(Int32 to Integer) |
Converts from int to Datatype.Integer.
| |
(Integer to Int32) |
Converts from Datatype.Integer to int.
| |
Inequality |
Compares an int value with a Datatype.Integer value.
|
See Also