IntegerConverter Class

The IntegerConverter class converts types to and from the integer datatype.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public class IntegerConverter : TypeConverter

The IntegerConverter type exposes the following members.

Constructors
  NameDescription
Public methodIntegerConverter
Initializes a new instance of the IntegerConverter class
Top
Methods
  NameDescription
Public methodCanConvertFrom
Checks whether the conversion can be made from the source type to the integer datatype.
(Overrides TypeConverterCanConvertFrom(ITypeDescriptorContext, Type).)
Public methodCanConvertTo
Checks whether the conversion can be made from the integer datatype to the destination type.
(Overrides TypeConverterCanConvertTo(ITypeDescriptorContext, Type).)
Public methodConvertFrom
Converts an object from the given culture to the Tekla.Structures.Datatype.Integer type.
(Overrides TypeConverterConvertFrom(ITypeDescriptorContext, CultureInfo, Object).)
Public methodConvertTo
Converts an object from the the integer datatype to the given destination type.
(Overrides TypeConverterConvertTo(ITypeDescriptorContext, CultureInfo, Object, Type).)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next