BinaryFilterExpressionCollectionInsert Method

Inserts an element in the collection at a specified index.

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public void Insert(
	int Index,
	BinaryFilterExpressionItem Item
)

Parameters

Index
Type: SystemInt32
The zero-based index at which the item shoud be inserted.
Item
Type: Tekla.Structures.FilteringBinaryFilterExpressionItem
The item to insert. This value cannot be null.

Implements

IListTInsert(Int32, T)
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when the supplied item is null.
ArgumentExceptionThrown when the supplied index is out of bounds.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next