DistanceListInsert Method

Inserts an item at the specified position.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public void Insert(
	int index,
	Distance item
)

Parameters

index
Type: SystemInt32
The index of the insertion point.
item
Type: Tekla.Structures.DatatypeDistance
The item to be inserted.

Implements

IListTInsert(Int32, T)
Examples
This example shows how to insert a new Distance instance at the beginning of the DistanceList.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           Distance[] distances = { new Distance(30.2), new Distance(2.3) };
           DistanceList distanceList = new DistanceList(distances);

           distanceList.Insert(0, new Distance(2));
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next