DistanceListIndexOf Method

Returns the index of the first matching item in the list.

Namespace:  Tekla.Structures.Datatype
Assembly:  Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Examples
This example shows how to determine the index of the first matching Distance instance in a DistanceList.
using Tekla.Structures.Datatype;

public class Example
{
       public void Example1()
       {
           // We'll use this distance list to demonstrate the IndexOf method.
           DistanceList distanceList = new DistanceList(new Distance[]
                                                       {
                                                           new Distance(30.2),
                                                           new Distance(30.2),
                                                           new Distance(30.2),
                                                           new Distance(50),
                                                           new Distance(2.3),
                                                           new Distance(2.3),
                                                       });
           int index = distanceList.IndexOf(new Distance(2));

           if(index < 0)
           {
               // Not found.
           }
           else
           {
               // Found, do something with the index.
           }
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next