CatalogHandlerImportRebarItems Method |
Imports rebar items (*.rexp) from folder to reinforcement catalog.
Import overrides the existing rebar item in the catalog without any warnings.
Namespace: Tekla.Structures.Catalogs
Assembly: Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
Parameters
- path
- Type: SystemString
The path to be used for import.
Return Value
Type: Booleantrue if successful.
Examples
using System; using Tekla.Structures.Catalogs; public class Example { public void Example1() { if (new CatalogHandler().ImportRebarItems(System.IO.Path.GetTempPath())) Console.WriteLine("Rebar items imported successfully to catalog."); } }
See Also