CatalogHandlerImportParametricProfileItems Method

Imports parametric profile items (*.uel) from folder to profile catalog. Import overrides the existing profiles in the catalog without any warnings.

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
public bool ImportParametricProfileItems(
	string path
)

Parameters

path
Type: SystemString
The path to be used for import.

Return Value

Type: Boolean
true if successful.
Examples
using System;
using Tekla.Structures.Catalogs;

public class Example
{
       public void Example1()
       {
           if (new CatalogHandler().ImportParametricProfileItems(System.IO.Path.GetTempPath()))
               Console.WriteLine("Parametric profiles imported successfully to catalog.");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next