IFC2X3_ParametricObject_ZShapeProfile Class

The IFC2X3_ParametricObject_ZShapeProfile class contains the Z-shape profile definition.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_ZShapeProfile

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
[SerializableAttribute]
public sealed class IFC2X3_ParametricObject_ZShapeProfile : ReferenceModelObjectAttribute

The IFC2X3_ParametricObject_ZShapeProfile type exposes the following members.

Properties
  NameDescription
Public propertyDepth
The depth.
Public propertyEdgeRadius
The edge radius.
Public propertyFilletRadius
The fillet radius.
Public propertyFlangeThickness
The flange thickness.
Public propertyFlangeWidth
The flange width.
Public propertyWebThickness
The web thickness.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next