IFC2X3_ParametricObject_TShapeProfile Class |
The IFC2X3_ParametricObject_TShapeProfile class contains the T-shape profile definition.
Inheritance Hierarchy
SystemObject
Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_TShapeProfile
Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_TShapeProfile
Namespace: Tekla.Structures.Model.Collaboration
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The IFC2X3_ParametricObject_TShapeProfile type exposes the following members.
Properties
Name | Description | |
---|---|---|
Depth |
The depth.
| |
Description |
The description of the product.
(Inherited from ReferenceModelObjectAttribute.) | |
Extrusion |
The extrusion vector.
(Inherited from ReferenceModelObjectAttribute.) | |
FilletRadius |
The fillet radius.
| |
FlangeEdgeRadius |
The flange edge radius.
| |
FlangeSlope |
The flange slope.
| |
FlangeThickness |
The flange thickness.
| |
FlangeWidth |
The flange width.
| |
Name |
The name of the product.
(Inherited from ReferenceModelObjectAttribute.) | |
ObjectType |
The object type of the product.
(Inherited from ReferenceModelObjectAttribute.) | |
Origin |
The origin of the extrusion.
(Inherited from ReferenceModelObjectAttribute.) | |
ProfileName |
The name of the profile (often empty).
(Inherited from ReferenceModelObjectAttribute.) | |
WebEdgeRadius |
The web edge radius.
| |
WebSlope |
The web slope.
| |
WebThickness |
The web thickness.
| |
xDir |
The X-axis direction.
(Inherited from ReferenceModelObjectAttribute.) |
See Also