IFC2X3_ParametricObject_TShapeProfile Class |
The IFC2X3_ParametricObject_TShapeProfile class contains the T-shape profile definition.
Inheritance Hierarchy
SystemObject
Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_TShapeProfile
Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_TShapeProfile
Namespace: Tekla.Structures.Model.Collaboration
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2024.0.0+a110b435391768740483e3032720a566518c9a63
Syntax
The IFC2X3_ParametricObject_TShapeProfile type exposes the following members.
Properties
Name | Description | |
---|---|---|
Depth |
The depth.
FilletRadius |
The fillet radius.
| |
FlangeEdgeRadius |
The flange edge radius.
| |
FlangeSlope |
The flange slope.
| |
FlangeThickness |
The flange thickness.
| |
FlangeWidth |
The flange width.
WebEdgeRadius |
The web edge radius.
| |
WebSlope |
The web slope.
| |
WebThickness |
The web thickness.
See Also